P20/A20 Loan - plus cable amplifier starter kit

User avatar
Dr Bunsen Honeydew
Posts: 27917
Joined: Wed Jul 11, 2012 7:26 pm
Location: Muppet Labs
Great Britain

Re: P20/A20 Loan - plus cable amplifier starter kit

Unread post by Dr Bunsen Honeydew » Wed Jan 10, 2018 4:37 pm

1st time this sort of problem with them for me, you must have a rogue driver who needs to be reported.

User avatar
Classicrock
Posts: 1853
Joined: Sun Apr 07, 2013 12:51 pm
Location: Bristol
Great Britain

Re: P20/A20 Loan - plus cable amplifier starter kit

Unread post by Classicrock » Wed Jan 31, 2018 10:57 am

Put me down on the list but won't need them for about 3 weeks when builders hopefully will have finished at the back or I decorate the front room to relocate the hi-fi.

scotty38
Posts: 71
Joined: Sat Jan 20, 2018 12:51 am
Great Britain

Re: P20/A20 Loan - plus cable amplifier starter kit

Unread post by scotty38 » Thu Feb 08, 2018 11:23 pm

Could I possibly try this please?

Shamanic
Posts: 20
Joined: Tue Oct 31, 2017 1:33 pm
Location: Llanerfyl
Wales

Re: P20/A20 Loan - plus cable amplifier starter kit

Unread post by Shamanic » Sun Feb 11, 2018 3:14 pm

On their way to Scotty38 tomorrow for delivery Tuesday.

scotty38
Posts: 71
Joined: Sat Jan 20, 2018 12:51 am
Great Britain

Re: P20/A20 Loan - plus cable amplifier starter kit

Unread post by scotty38 » Sun Feb 11, 2018 5:56 pm

Great stuff thank you.

Classicrock, let me know when you're ready and I'll send them on to you....

scotty38
Posts: 71
Joined: Sat Jan 20, 2018 12:51 am
Great Britain

Re: P20/A20 Loan - plus cable amplifier starter kit

Unread post by scotty38 » Tue Feb 13, 2018 10:52 pm

Well it arrived today so thanks to all concerned and I'm very pleased with it so far!

I do have an "operational" type query though....

With just my TT plugged into "Direct" it works as it should but if I have, say, my squeezebox plugged into "CD" then the TT is very low output unless I switch the selector to "AUX" then the volume increases but not to the level when just plugged in by itself.

Earlier this evening I had my TT in "AUX" with the Squeezebox in "CD". Squeezebox was barely audible. I moved it to "Direct" and all fine.

Am I missing something here or doing something daft?

Thanks....

scotty38
Posts: 71
Joined: Sat Jan 20, 2018 12:51 am
Great Britain

Re: P20/A20 Loan - plus cable amplifier starter kit

Unread post by scotty38 » Wed Feb 14, 2018 8:56 am

Ok, so further research suggests not using direct at the same time as other inputs although it should work if other input devices are off. This was the way I was using it but would the general advice be direct alone or not at all?

User avatar
Dr Bunsen Honeydew
Posts: 27917
Joined: Wed Jul 11, 2012 7:26 pm
Location: Muppet Labs
Great Britain

Re: P20/A20 Loan - plus cable amplifier starter kit

Unread post by Dr Bunsen Honeydew » Wed Feb 14, 2018 9:41 am

Alone or not at all.

scotty38
Posts: 71
Joined: Sat Jan 20, 2018 12:51 am
Great Britain

Re: P20/A20 Loan - plus cable amplifier starter kit

Unread post by scotty38 » Wed Feb 14, 2018 9:46 am

Great, thank you.

scotty38
Posts: 71
Joined: Sat Jan 20, 2018 12:51 am
Great Britain

Re: P20/A20 Loan - plus cable amplifier starter kit

Unread post by scotty38 » Sun Feb 18, 2018 7:05 pm

Just thought I'd add an update as I've had these a few days now....

I can't quite put my finger on why but they're rubbish.......

Mind you, having said that, when I get my backside into gear I'll be ordering:

P90sa
A40
some LS5
some SC and some SSC

Post Reply